ios - 领域:模块是由较旧版本的编译器创建的,无法构建objective-c模块

ios - 领域:模块是由较旧版本的编译器创建的,无法构建objective-c模块,第1张

ios - 领域:模块是由较旧版本的编译器创建的,无法构建objective-c模块,enter image description here,第2张

我已按照提供的步骤添加此链接https://realm.io/docs/swift/latest/

中的framewowrk

它给出了这个错误可能是什么问题?

是因为我使用旧版xcode编译,因为我有最新的xcode 7 beta版?

如果是这样,我该如何解决?

最佳答案:

3 个答案:

答案 0 :(得分:6)

在您可以在Swift 2.0项目中使用Realm Swift之前,您必须等待我们支持Swift 2.0(#2062)。

因为在旧版本编译器中构建的Swift编写的框架无法在Xcode 7中使用。因此,需要使用Xcode 7的编译器重新构建。但是,需要使用Swift 2 Xcode 7;我们正在努力使RealmSwift.framework适应Swift 2。

答案 1 :(得分:3)

我通过执行以下操作让Realm与Swift 2一起工作(这是来自内存)

  1. Checkout Swift-2.0分支https://github.com/realm/realm-cocoa/tree/swift-2.0
  2. 通过运行/build.sh ios-swift
  3. 进行构建
  4. 将Realm.framework和RealmSwift.framework复制到项目中
  5. 使用let realm = try! Realm()作为我的初始化程序代替let realm = Realm()
  6. 我将Carthage用于我的所有框架,所以为了保持统一,我将RealmSwift和Realm框架复制到carthage/build/ios directory并且/usr/local/bin/carthage copy-frameworks构建脚本选择它们

    答案 2 :(得分:0)

    由于某种原因,这也随机地开始发生在我身上。手动编译swift-2.0分支并没有最终完成工作。

    我最终将整个项目转换为Swift 2.1,并使用预编译的框架。现在我已经开始运作了。

    FWIW - 从2.0转换到2.1并不像1.0或1.2的任何其他转换那样痛苦。

    本文经用户投稿或网站收集转载,如有侵权请联系本站。

发表评论

0条回复