可以在iOS 9上运行Swift 1代码吗?

可以在iOS 9上运行Swift 1代码吗?,第1张

我想知道是否有人知道Swift(版本1)代码是否能够在iOS 9上运行,或者是否需要更新语法以允许它。我假设您可能没有 来更新代码,但如果有人有任何意见,请分享!

最佳答案:

1 个答案:

答案 0 :(得分:13)

Xcode 7将附带一个Swift Migrator工具(类似于Xcode 6中使用的Swift 1.1 to 1.2 migrator),这将帮助开发人员迁移Swift 1.2项目以使用Swift 2。

在7之前的Xcode版本中使用Swift 1.x编写的项目将在iOS 9上运行。使用Xcode 7编写的任何项目都必须使用Swift 2。

有关详细信息,请查看Apple开发者门户网站上的Swift Resources页面

本文经用户投稿或网站收集转载,如有侵权请联系本站。

发表评论

0条回复